Home » The VFD Conundrum

The VFD Conundrum

After bringing my second PCNC1100 almost back to full fledged life, there is still one item puzzling me! The spindle on this machine moved at 2X the command speed. I know the belt is where it is supposed to be, the pulley has been assembled correctly and MACH3 has been configured properly (there really isn’t much you can play within MACH3.)

Having two machines, you would imagine it would be piece of cake to compare both VFD units and VOILA! find the difference, right? ERRRR!!! WRONG-O!

As it turns out, comparing both VFDs does show one difference except that it doesn’t make any sense.

Before I go on, allow me to post the Emerson Industrial Automation Commander SK’s manual in case you want to drill your head with the preposterous 200 page long manual in PDF format: COMMANDER SK MANUAL.

Here is where this is squashing my brain:

1. A quick look at the manual shows there is one parameter (#24) which deals with customer scaling factor. You would imagine that the machine running at 2X would have a 2.0 in this position and the other machine a 1.0. Except they both have a 1.0 at this position. OK…

2. As I keep comparing parameters one by one, the only where I see a meaningful difference is address 65 which according to the manual is an User Configurable Parameter. Clearly Tormach must have done their own programming and used this parameter because the default is supposed to be 0. On one machine I see 8.5 and the other 14.3. Not twice, which is what puzzles me.

You would imagine the solution is to change address 65 so they match, but not so fast! What if this parameter is meant to be different from machine to machine? Had they been 2X the size that would hint to this being the place to change, but they are not 2X apart!

Or maybe there is something else I am overlooking? Everything is possible!

UPDATE 2/5/2014

Yes, EVERYTHING IS POSSIBLE! And in this case what was possible (not that I thought it was impossible) was my own moronicity.

This is one of the simplest solutions I have encountered in my whole life. The problem occurred because I thought I was following the spindle speed configuration instructions, except that I wasn’t. To make the story short, when you run PCNC COnfig to type in that number the VFD reads while running at 500 RPM, you have to be running in low gear. If you happen to have the machine in high gear, you will go at twice the speed. ERRRRR!!!!

Notice you need to configure the low gear both physically as well as in MACH3. Then run the spindle at 500 RPM and whatever you read on the VFD display, you enter within PCNCCONFIG.

This dinky little detail was present on both the PCNC 1100 manual as well as the Windows Application and somehow I still didn’t see it. Oh well problem solved and many more to come!

 

Leave a Reply

Your email address will not be published. Required fields are marked *